Envie De Calculer Une Valeur Absolue Dans Excel ?

Temps de lecture : 3 minutes

La Fonction Excel ABS permet de calculer la valeur absolue du nombre passé en argument. Très simple d’utilisation, elle ne prend qu’un seul argument.

Comment utiliser la fonction ABS dans Excel pour obtenir la Valeur Absolue d’un Nombre, d’une cellule, ou la somme des valeurs absolues d’une plage de cellules ? Nous allons voir en détail quelques exemples dans ce court article.

Fonction Excel ABS
Fonction Excel : ABS

Description de la fonction ABS

La valeur absolue d’un nombre correspond à la distance entre ce nombre et 0.

La description de la fonction ABS dans Excel suffit à expliquer simplement son utilité : « Renvoie la valeur absolue d’un nombre, un nombre sans son signe ».

Ainsi, les nombres négatifs sont convertis en nombres positifs, tandis que les nombres positifs restent inchangés.

NombreValeur Absolue
11
-1010

Syntaxe de la fonction ABS

La fonction ABS ne prend qu’un seul argument.

=ABS(Nombre)

« Nombre » correspond au nombre réel pour lequel on souhaite obtenir la valeur absolue.

Le nombre peut être passé directement dans la fonction ou par référence sur une cellule.

Comment utiliser la fonction ABS : exemples

Voyons quelques exemples d’utilisation de la fonction ABS.

Fonction-Excel-ABS-Exemples
Exemples d'utilisation de la Fonction Excel ABS

1. ABS sur un Nombre Positif

Dans cet exemple, on fourni directement un nombre positif en argument, la fonction retourne le nombre sans son signe, donc le même nombre.
Nombre originalFormuleRésultat
8.69=ABS(8.69)8.69
2630=ABS(2630)2630

2. ABS sur un Nombre Négatif

Dans cet exemple, on fourni directement un nombre négatif en argument, la fonction retourne sa valeur absolue, c’est à dire le nombre sans son signe.

Nombre originalFormuleRésultat
-7.32=ABS(-7.32)7.32
-389=ABS(-389)389

3. ABS sur une Cellule Excel

Pour finir, on fournit en argument une référence sur une cellule qui contient un nombre. La fonction retourne là encore la valeur absolue du nombre de la cellule de référence.
Adresse CelluleValeur CelluleFormuleRésultat
A112.3=ABS(A1)12.3
C2-46=ABS(C2)46
B4-99.9=ABS(B4)99.9

Somme Des Valeurs Absolues d'Une Plage De Cellules : Combiner SOMMEPROD et ABS

La fonction SOMMEPROD permet à la base d’effectuer la somme de la multiplication de plusieurs matrices passées en argument. Mais cette fonction accepte aussi de ne prendre qu’un seul argument. Ainsi utiliser SOMMEPROD sur une seule plage de cellule en argument reviendra au même qu’avec l’utilisation de la fonction SOMME. En revanche, puisque la fonction SOMMEPROD intègre le calcul matriciel, il est ainsi possible d’y imbriquer la fonction ABS en utilisant en argument de cette dernière une plage de cellules.

=SOMMEPROD(ABS(A1:A3))

Dans l’exemple ci-dessus, si les cellules contiennent les valeurs ci-dessous,

Adresse CelluleValeur Cellule
A1-1
A2-2
A3-10

Alors le résultat de la formule sera 13 (1 + 2 + 10).

Partager :

Laisser un commentaire