Moyenne Excel : Conditionnelle, Arithmétique, Pondérée

Temps de lecture : 5 minutes

Plusieurs fonctions sont disponibles dans Excel pour calculer une moyenne arithmétique : MOYENNE, MOYENNE.SI, MOYENNE.SI.ENS ou AVERAGEA.

Comme nous le verrons, l’utilisation de certaine de ces fonctions permet le calcul d’une moyenne conditionnelle permettant de ne prendre en compte les valeurs qui respectent un ou plusieurs critères définis.

Moyenne Excel
Excel : Moyenne arithmétique, conditionnelle ou pondérée

Nous pouvons également être amenés à vouloir calculer une moyenne pondérée, dans ce cas on se tournera vers une combinaison de SOMMEPROD et SOMME.

Nous allons détailler dans cet article comment utiliser chacune de ces fonctions.

Si vous avez des difficultés ou une question, n’hésitez pas à commenter ou me contacter.

Vous pouvez également retrouver la liste des fonctions Excel, leur description et leur traduction anglaise sur cette page.

Fonction MOYENNE : Calculer une moyenne arithmétique dans Excel

La fonction MOYENNE (version anglaise : AVERAGE) « renvoie la moyenne (espérance arithmétique) des arguments qui peuvent être des nombres, des noms, des matrices, ou des références contenant des nombres ».

Sous Excel, la fonction et ses arguments se présentent sous la forme suivante :

=MOYENNE(Nombre1, [Nombre2], ...)

Il nous est possible de fournir jusqu’à 255 arguments pour cette fonction (Une plage de plusieurs cellules comptant comme un seul argument).

La fonction ignorera toute valeur non numérique ou cellule vide dans son calcul.

Dans son utilisation la plus courante, on fournira une plage de cellule en argument de la fonction, mais il nous est tout à fait possible de fournir plusieurs valeurs séparément.

=MOYENNE(A1:A5)
=MOYENNE(2, 4, 6, 8, 10)
=MOYENNE(A1, A2, A3, 20, 40)
MOYENNE Excel - Exemple
MOYENNE Excel - Exemple

Reproduire une moyenne arithmétique avec les fonctions SOMME et NB

Cette section est simplement à titre illustratif pour répliquer la fonction MOYENNE que nous venons de voir, on préferera bien entendu utiliser cette dernière.

La fonction SOMME (version anglaise : SUM) « calcule la somme des nombres dans une plage de cellule ».

La fonction NB (Version anglaise : COUNT) « détermine le nombre de cellules d’une plage contenant des nombres ».

Sous Excel, ces deux fonctions et leurs arguments se présentent sous la forme suivante :

=SOMME(Nombre1, [Nombre2], ...)
=NB(Valeur1, [Valeur2], ...)

Puisque la moyenne arithmétique n’est autre que la somme d’un ensemble de valeurs numériques divisée par le nombre de ces valeurs numériques, nous pouvons répliquer la fonction MOYENNE en calculant:

=SOMME(A1:A5) / NB(A1:A5)
SOMME et NB Excel - Exemple
SOMME et NB Excel - Exemple

Moyenne arithmétique avec la fonction AVERAGEA - Pour inclure les cellules non numériques

La fonction AVERAGEA (version anglaise : AVERAGEA) « renvoie la moyenne (espérance arithmétique) de ses arguments, en considérant que le texte et la valeur logique FAUX dans les arguments = 0 ; VRAI = 1. Les arguments peuvent être des nombres, des noms, des matrices ou des références ».

Sous Excel, la fonction et ses arguments se présentent sous la forme suivante :

=AVERAGEA(Valeur1, [Valeur2], ...)

Sur un ensemble de données uniquement numériques et identiques, MOYENNE et AVERAGEA donneront le même résultat.

En revanche, sur un ensemble de données contenant des valeurs numériques ainsi que du texte ou des valeurs logiques (VRAI/FAUX), MOYENNE considérera uniquement les valeurs numériques dans son calcule, alors que AVERAGEA interprétera le texte comme valeur 0, la valeur logique FAUX comme valeur 0 et la valeur logique VRAI comme valeur 1. Dans le cas des deux fonctions, les cellules vides seront ignorées.

AVERAGEA vs MOYENNE Excel - Exemple
AVERAGEA vs MOYENNE Excel - Exemple

Moyenne Conditionnelle dans Excel

Moyenne avec une condition : avec la fonction MOYENNE.SI

La fonction MOYENNE.SI (Version anglaise : AVERAGEIF) « détermine la moyenne (espérance arithmétique) des cellules satisfaisant une condition ou des critères particuliers ».

Sous Excel, la fonction et ses arguments se présentent sous la forme suivante :

=MOYENNE.SI(Plage, Critères, [Plage Moyenne])

Si la Plage de cellules contenant les valeurs numériques pour lesquelles on souhaite obtenir la moyenne est la même que celle sur laquelle on souhaite poser une condition, alors on utilisera uniquement 2 arguments : Plage et Critères. Cela peut être le cas si l’on souhaite faire la moyenne des valeurs uniquement plus grandes que 0 (ou autre valeur):

MOYENNE.SI(A1:A100, ">0")

En revanche, si l’on souhaite se baser sur un autre critère situé dans une plage de cellules équivalente (de même taille) à notre plage de cellules pour laquelle on souhaite calculer la moyenne, alors on utilisera 3 arguments : Plage, Critères, Plage Moyenne, comme illustré ci-dessous:

Nous disposons d’un ensemble de Ventes catégorisées par Région, Entitée, Départment: à titre illustratif (dénué de sens), nous souhaitons obtenir la moyenne des ventes par Entitée, ainsi que la Moyenne des ventes par Région.

MOYENNE SI Excel - Exemple
MOYENNE SI Excel - Exemple

Moyenne avec plusieurs critères : avec la fonction MOYENNE.SI.ENS

La fonction MOYENNE.SI.ENS (Version anglaise : AVERAGEIFS) « détermine la moyenne (espérance arithmétique) des cellules spécifiées par un ensemble de conditions ou de critères ».

Sous Excel, la fonction et ses arguments se présentent sous la forme suivante :

=MOYENNE.SI.ENS(Plage Moyenne, Plage Critères 1, Critères 1, [Plage Critères 2], [Critères 2], ...)

On donnera au minimum 3 arguments pour cette fonction.

Plage Moyenne correspond aux cellules contenant les valeurs numériques pour lesquelles on souhaite calculer la moyenne.

Plage Critères correspond aux cellules qui sera utilisée pour évaluer la conditions « Critère »

Critères correspond à la condition à laquelle chaque cellule de la Plage Critères devra répondre pour être incluse dans le calcul de la moyenne.

Reprenons le même exemple que précédemment avec cette fois ci deux conditions à appliquer sur notre moyenne : Région et Entité.

MOYENNE SI ENS Excel - Exemple
MOYENNE SI ENS Excel - Exemple

Moyenne Pondérée dans Excel

Combinaison de SOMMEPROD et SOMME pour calculer une moyenne pondérée

La fonction SOMME (Version anglaise : SUM) « Calcule la somme des nombres dans une plage de cellule ».

La fonction SOMMEPROD (Version anglaise : SUMPRODUCT) « donne la somme des produits des plages ou matrices correspondantes ».

Sous Excel, ces deux fonctions et leurs paramètres se présentent sous la forme suivante :

=SOMME(Nombre1, [Nombre2], ...)
=SOMMEPROD(Matrice1, [Matrice2], ...)

Les Matrices données arguments de SOMMEPROD doivent être de même taille. La fonction effectuera le produit des éléments correspondants de chaque matrice et sommera ensuite ces produits.

Combiner ces deux fonctions nous permettra de calculer une moyenne pondérée :

=SOMMEPROD(Eléments, Poids) / SOMME(Poids)
(Eléments x Poids de chaque élément) / (Poids Total : 100%)

On présente ci-dessous une table de données avec des résultats de test de plusieurs individus. Chaque test a une pondération différente donnée dans une autre table :

MOYENNE Pondérée Excel - Exemple
MOYENNE Pondérée Excel - Exemple
Partager :

Laisser un commentaire