Fonctions Excel : Moyenne, Moyenne.Si, Moyenne.Si.Ens Et Calcul De Moyenne Pondérée

Temps de lecture : 5 minutes

Plusieurs fonctions sont disponibles dans Excel pour calculer une moyenne arithmétique : MOYENNE, MOYENNE.SI, MOYENNE.SI.ENS ou AVERAGEA.

Nous pouvons également être amenés à vouloir calculer une moyenne pondérée, dans ce cas on utilisera une combinaison de SOMMEPROD et SOMME.

Nous allons détailler dans cet article comment utiliser chacune de ces fonctions.

Moyenne Excel
Fonctions Excel : Moyenne, Moyenne.Si et Moyenne.Si.Ens

Avec la fonction MOYENNE (Version anglaise: AVERAGE)

La fonction MOYENNE « renvoie la moyenne (espérance arithmétique) des arguments qui peuvent être des nombres, des noms, des matrices, ou des références contenant des nombres ».

Sous Excel, la fonction et ses paramètres se présentent sous la forme suivante:

MOYENNE(Nombre1, [Nombre2], …)

Il nous est possible de fournir jusqu’à 255 arguments pour cette fonction (Une plage de plusieurs cellules comptant comme un seul argument).

La fonction ignorera toute valeur non numérique ou cellule vide dans son calcul.

Dans son utilisation la plus courante, on fournira une plage de cellule en argument de la fonction, mais il nous est tout à fait possible de fournir plusieurs valeurs séparément.

=MOYENNE(A1:A5)
=MOYENNE(2, 4, 6, 8, 10)
=MOYENNE(A1, A2, A3, 20, 40)
MOYENNE Excel - Exemple
MOYENNE Excel - Exemple

Avec les fonctions SOMME et NB (Versions anglaises: SUM et COUNT)

Cette section est simplement à titre illustratif pour répliquer la fonction MOYENNE que nous venons de voir, on préferera bien entendu utiliser cette dernière.

La fonction SOMME « calcule la somme des nombres dans une plage de cellule ».

La fonction NB « détermine le nombre de cellules d’une plage contenant des nombres ».

Sous Excel, ces deux fonctions et leurs paramètres se présentent sous la forme suivante:

SOMME(Nombre1, [Nombre2], …)

NB(Valeur1, [Valeur2], …)

Puisque la moyenne arithmétique n’est autre que la somme d’un ensemble de valeurs numériques divisée par le nombre de ces valeurs numériques, nous pouvons répliquer la fonction MOYENNE en calculant:

=SOMME(A1:A5) / NB(A1:A5)
SOMME et NB Excel - Exemple
SOMME et NB Excel - Exemple

Moyenne Arithmétique Conditionnelle dans Excel

Avec la fonction MOYENNE.SI - Une seule condition (Version anglaise: AVERAGEIF)

La fonction MOYENNE.SI « détermine la moyenne (espérance arithmétique) des cellules satisfaisant une condition ou des critères particuliers ».

Sous Excel, la fonction et ses paramètres se présentent sous la forme suivante:

MOYENNE.SI(Plage, Critères, [Plage Moyenne])

Si la Plage de cellules contenant les valeurs numériques pour lesquelles on souhaite obtenir la moyenne est la même que celle sur laquelle on souhaite poser une condition, alors on utilisera uniquement 2 arguments: Plage et Critères. Cela peut être le cas si l’on souhaite faire la moyenne des valeurs uniquement plus grandes que 0 (ou autre valeur):

MOYENNE.SI(A1:A100, ">0")

En revanche, si l’on souhaite se baser sur un autre critère situé dans une plage de cellules équivalente (de même taille) à notre plage de cellules pour laquelle on souhaite calculer la moyenne, alors on utilisera 3 arguments: Plage, Critères, Plage Moyenne, comme illustré ci-dessous:

Nous disposons d’un ensemble de Ventes catégorisées par Région, Entitée, Départment: à titre illustratif (dénué de sens), nous souhaitons obtenir la moyenne des ventes par Entitée, ainsi que la Moyenne des ventes par Région.

MOYENNE SI Excel - Exemple
MOYENNE SI Excel - Exemple

Avec la fonction MOYENNE.SI.ENS - Multiple conditions (Version anglaise: AVERAGEIFS)

La fonction MOYENNE.SI.ENS « détermine la moyenne (espérance arithmétique) des cellules spécifiées par un ensemble de conditions ou de critères ».

Sous Excel, la fonction et ses paramètres se présentent sous la forme suivante:

MOYENNE.SI.ENS(Plage Moyenne, Plage Critères 1, Critères 1, [Plage Critères 2], [Critères 2], …)

On donnera au minimum 3 arguments pour cette fonction.

Plage Moyenne correspond aux cellules contenant les valeurs numériques pour lesquelles on souhaite calculer la moyenne.

Plage Critères correspond aux cellules qui sera utilisée pour évaluer la conditions « Critère »

Critères correspond à la condition à laquelle chaque cellule de la Plage Critères devra répondre pour être incluse dans le calcul de la moyenne.

Reprenons le même exemple que précédemment avec cette fois ci deux conditions à appliquer sur notre moyenne: Région et Entité.

MOYENNE SI ENS Excel - Exemple
MOYENNE SI ENS Excel - Exemple

Avec la fonction AVERAGEA - Pour inclure les cellules non numériques (AVERAGEA)

La fonction AVERAGEA « renvoie la moyenne (espérance arithmétique) de ses arguments, en considérant que le texte et la valeur logique FAUX dans les arguments = 0 ; VRAI = 1. Les arguments peuvent être des nombres, des noms, des matrices ou des références ».

Sous Excel, la fonction et ses paramètres se présentent sous la forme suivante:

AVERAGEA(Valeur1, [Valeur2], …)

Sur un ensemble de données uniquement numériques et identiques, MOYENNE et AVERAGEA donneront le même résultat.

En revanche, sur un ensemble de données contenant des valeurs numériques ainsi que du texte ou des valeurs logiques (VRAI/FAUX), MOYENNE considérera uniquement les valeurs numériques dans son calcule, alors que AVERAGEA interprétera le texte comme valeur 0, la valeur logique FAUX comme valeur 0 et la valeur logique VRAI comme valeur 1. Dans le cas des deux fonctions, les cellules vides seront ignorées.

AVERAGEA vs MOYENNE Excel - Exemple
AVERAGEA vs MOYENNE Excel - Exemple

Moyenne Pondérée dans Excel

Combinaison de SOMMEPROD et SOMME (Versions anglaises: SUMPRODUCT et SUM)

La fonction SOMME « Calcule la somme des nombres dans une plage de cellule ».

La fonction SOMMEPROD « donne la somme des produits des plages ou matrices correspondantes ».

Sous Excel, ces deux fonctions et leurs paramètres se présentent sous la forme suivante:

SOMME(Nombre1, [Nombre2], …)

SOMMEPROD(Matrice1, [Matrice2], …)

Les Matrices données arguments de SOMMEPROD doivent être de même taille. La fonction effectuera le produit des éléments correspondants de chaque matrice et sommera ensuite ces produits.

Combiner ces deux fonctions nous permettra de calculer une moyenne pondérée:

=SOMMEPROD(Eléments, Poids) / SOMME(Poids)
(Eléments x Poids de chaque élément) / (Poids Total : 100%)
MOYENNE Pondérée Excel - Exemple
MOYENNE Pondérée Excel - Exemple
Partager :

Laisser un commentaire